Bug report #21082

QGIS crashes when loading mesh layers

Added by matteo ghetta over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Peter Petrik
Category:Data Provider/MDAL
Affected QGIS version:3.5(master) Regression?:Yes
Operating System:linux and windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:28900

Description

In attach some samples of mesh layers (grib2). No matter which one, but when loaded both by Browser or by Data Source button, QGIS crashes, saying just "signal aborted"

20190123_074103_GFS_P25_.grb2 (1.36 MB) matteo ghetta, 2019-01-24 08:49 AM

20190122_112252_GFS_P25_.grb2 (118 KB) matteo ghetta, 2019-01-24 08:49 AM

20190123_074448_ICON_EU_P06_.grb2 (2.21 MB) matteo ghetta, 2019-01-24 08:49 AM

Screenshot 2019-01-24 at 11.11.10.png (119 KB) Peter Petrik, 2019-01-24 11:10 AM

History

#1 Updated by Peter Petrik over 1 year ago

works for me on master , probably duplicate of https://github.com/lutraconsulting/MDAL/issues/79 and fixed by https://github.com/qgis/QGIS/pull/8941

#2 Updated by matteo ghetta over 1 year ago

  • Status changed from Open to Closed

recompiled QGIS and confirmed the fix, thanks Peter!

Also available in: Atom PDF