Bug report #21056

Cannot commit data from QGIS 3.4.2 to sql server table with trigger

Added by Lars Ellebjerg over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/MSSQL
Affected QGIS version:3.4.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28874

Description

I have an issue committing data to a table in SQL Server 2012 where there is an "after update" trigger.

I get the error message " [Microsoft][ODBC SQL Server Driver][SQL Server]The target table 'dbo.vinterrydning_sti' of the DML statement cannot have any enabled triggers if the statement contains an OUTPUT clause without INTO clause. [Microsoft][ODBC SQL Server Driver][SQL Server]Statement(s) could not be prepared."

I can update the same data without any difficulties in QGIS 2.18.

Best regards
Lars Ellebjerg

History

#1 Updated by Lars Ellebjerg over 1 year ago

  • Status changed from Open to Closed

The issue is solved in 3.4.4.

Also available in: Atom PDF