Bug report #20940

Layout: Horizontal and vertical arrows cannot be selected using single click

Added by J. Dugge over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.2 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28759

Description

When the "Select/Move item" tool is active, unlocked layout items can be selected by clicking once within an item's bounding box. Arrows that run exactly horizontally (vertically) have a bounding box of zero height (width) and cannot be selected using a single click.

Interestingly, double-clicking such an arrow does select the arrow, but this requires very precise aim.

Instead of using the bounding box as the selection target, it would be more intuitive to use the visible pixels of the arrow, possibly using a small buffer (this seems to be what Inkscape does).

arrow_selection.qgz - QGIS project with a layout containing arrows for testing (2.84 KB) J. Dugge, 2019-01-08 09:12 AM

Associated revisions

Revision 1cdff21c
Added by Jürnjakob Dugge over 1 year ago

[layouts] Use polyline shape instead of bounding box for selection, makes polylines selectable via single click

Fixes #20940

Revision 33660ced
Added by Jürnjakob Dugge over 1 year ago

[layouts] Use polyline shape instead of bounding box for selection, makes polylines selectable via single click

Fixes #20940

(cherry picked from commit 1cdff21c85b97cc9b650022447d3d64c46088cf5)

History

#1 Updated by J. Dugge over 1 year ago

It is also not possible to select horizontal or vertical arrows using a rectangle selection when the ALT-modifier is used.

#2 Updated by Anonymous over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF