Bug report #20916

QGIS freezes Mac when opening and navigating folders

Added by Joe Bullard almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:Denis Rouzaud
Category:mac_os_specific
Affected QGIS version:3.4.3 Regression?:No
Operating System:Mac Mojave Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:28735

Description

Hi,

I have been experiencing this issue on 3.4.3 and 3.4.2 on Mac Mojave. When I open the application my mac will freeze for about 20 seconds. The same also occurs when attempting to navigate system files to save or open layers or projects etc.

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

Try with a new/clean profile.

#2 Updated by Lene Fischer almost 2 years ago

I have the same problems. QGIS 3.4.3 freeze when I try to open the 'Open Data Source manager'. I have an existing project open and want to add a new layer.
As suggested I have tried to open from another user profile and gets the same result.

In the beginning it was just a long period of waiting - now it freeze totally.

.... Now I have booted my computer - and some windows updates automaticly installes. Back to normal. Sorry for 'noise'
I use Windows 7
Regards
Lene Fischer

#3 Updated by Giovanni Manghi almost 2 years ago

so this is not macOS specific?

#4 Updated by Joe Bullard almost 2 years ago

Giovanni Manghi wrote:

Try with a new/clean profile.

I completely cleared QGIS and all dependancies, still happens

#5 Updated by Justin DeNormandie almost 2 years ago

I'm having the same problem on 2 different Mac machines (both running Mojave). It started with 3.4.2 and its still there on 3.4.3. My whole system freezes when using the" file picker" window. I can move my mouse around, but I cannot interact with any thing during the freeze.

I tried completely uninstalling QGIS (and python, GDAL) and reinstalling, but I still get the freezing.

#6 Updated by Darren Kavanagh almost 2 years ago

Probably duplicate of #20381.

#7 Updated by Justin DeNormandie almost 2 years ago

Yes, it's the same issue. I read the subject as meaning the freeze was only during launch, but from the discussion it is clearly the same issue.

#8 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Also available in: Atom PDF