Bug report #2090

crash during buffer

Added by jaanvajakas - about 12 years ago. Updated about 12 years ago.

Status:Closed
Priority:Low
Assignee:cfarmer -
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12150

Description

To reproduce:
1. create a new project in Quantum GIS 1.3.0,
2. add layer kirdem2.shp using Layers -> Add vector layer...,
3. Set layer units to meters in Settings -> Project properties...
4. Tools -> Geoprocessing tools -> Buffer(s), set buffer distance to -30, choose output file, click OK

Expected result: QGIS calculates inner buffer of 30 meters.

Actual result: QGIS crashes.

kirdem2.shp.zip - the input shapefile (same as in https://trac.osgeo.org/qgis/ticket/2089 but in EPSG:3301 coordinate system) (151 KB) jaanvajakas -, 2009-11-13 08:18 AM

Associated revisions

Revision 76abb782
Added by Jürgen Fischer about 12 years ago

fix #2090

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision c9eb2417
Added by Jürgen Fischer about 12 years ago

fix #2090

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer about 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

crash fixed in c9eb2417 (SVN r12279).

GEOS didn't produce a valid geometry. That probably because of islands that are to tiny for a -30m buffer.

Also available in: Atom PDF