Bug report #20846

Shape

Added by Sascha von Arx about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Geometry
Affected QGIS version:3.4.2 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:28665

Description

Some Areas from the Shapefiles "Zusatzobjekte_Freie_Zone_1_Fläche" (Attachement) weren't recognized from QGIS.
The not recognized Areas apparently differs from Export to Export?!

The Test with FME Import(shape2alt) shows the same Dataset which all areas are visible.

Shape-Areas-partial-not-recognized.zip - Some Areas from the Shape-File are missing in QGIS (865 KB) Sascha von Arx, 2018-12-19 11:44 AM

Complete-FME-Import-.png - In FME is the import complete (76.9 KB) Sascha von Arx, 2018-12-19 11:58 AM

Kanal_AW_Versickerungsbecken_Fläche.zip - geometry-Data is not available in QGIS (3.06 KB) Sascha von Arx, 2019-01-22 01:08 PM

Extensions.png (366 KB) Sascha von Arx, 2019-01-24 09:10 AM

Wasser_Fremdleitungen_B-Position.png (386 KB) Sascha von Arx, 2019-01-24 09:10 AM

Version.png (327 KB) Sascha von Arx, 2019-01-24 09:10 AM

Wasser_Fremdleitung_B_Position.shx (580 Bytes) Sascha von Arx, 2019-01-24 09:10 AM

Wasser_Fremdleitung_B_Position.shp (14.1 KB) Sascha von Arx, 2019-01-24 09:10 AM

Wasser_Fremdleitung_B_Position.dbf (74.4 KB) Sascha von Arx, 2019-01-24 09:10 AM

History

#1 Updated by Sascha von Arx about 1 year ago

Another Shapefile where the geometry-Data is not recognized.

#2 Updated by Giovanni Manghi about 1 year ago

  • Assignee deleted (Andreas Neumann)
  • Status changed from Open to Feedback

Sascha von Arx wrote:

Another Shapefile where the geometry-Data is not recognized.

can you be more specific? maybe with a screenshot comparison of areas visible in one software and that are not visible in qgis?

#3 Updated by Sascha von Arx about 1 year ago

On QGIS 3.0.3-Girona it Work's to see all Lines but on QGIS Version 3.4.2-Madeira some Lines are missing from file Wasser_Fremdleitung_B-Position.
Look on the Pictures, "Extensions" for the installed extensions, "Version" for the installed Version and the tested file is Wasser_Fremdleitung_B-Position.

Thanks for a solution for the new Versions. ;-)

#4 Updated by Giovanni Manghi about 1 year ago

Thanks for a solution for the new Versions. ;-)

please try with 3.4.4

#5 Updated by Sascha von Arx about 1 year ago

  • Assignee set to Giovanni Manghi

It seems to be working.
Thank you.

#6 Updated by Giovanni Manghi about 1 year ago

  • Assignee deleted (Giovanni Manghi)
  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Also available in: Atom PDF