Bug report #20778

Cannot delete individual vertex in lines

Added by Matthew Bodnar over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Editing
Affected QGIS version:3.4.2 Regression?:No
Operating System:WIN 10.0.17134 Build 17134 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:28598

Description

Hi,

I cannot delete individual vertex in this topo contour file with the vertex editor. I have to cut the line into pieces and delete the smaller segment entirely.

I receive a runtime-error for some reason, not sure if this is related (screenshot attached).

I have attached the data as a QLR, I apologize if this is due to my data but I thought there may be a editing issue somewhere.

Regards

Test_Topo_5m_Contours.qlr (15 KB) Matthew Bodnar, 2018-12-11 05:44 PM

Capture.PNG (29.9 KB) Matthew Bodnar, 2018-12-11 05:44 PM

05_Issues.zip (4.36 MB) Matthew Bodnar, 2018-12-11 06:56 PM

History

#1 Updated by Saber Razmjooei over 1 year ago

  • Status changed from Open to Feedback

You need to attach SMM_Kluane_SB_5m Shape file (shp, shx, dbf and prj)

#2 Updated by Matthew Bodnar over 1 year ago

Hi,

The shapefiule was too big so I had to clip a portion, export as Geopackage and put into this compressed folder.

I still cannot delete a node/vertex. I can highight a vertex blue and press the delete key... it will run the script but the vertex remains.

#3 Updated by Giovanni Manghi over 1 year ago

works as expected here (QGIS master, Win10), try with a new/clean profile.

#4 Updated by Matthew Bodnar over 1 year ago

Giovanni Manghi wrote:

works as expected here (QGIS master, Win10), try with a new/clean profile.

Yes, that has solved it. My apologies. I do not know why the .ini for the profile is corrupted..

Thank you

#5 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF