Bug report #20737

Can't open shapefiles from https websites on windows

Added by Chris Chauvot about 1 year ago. Updated 10 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:3.4.2 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:28557

Description

I can't achieve to load specific shapefiles from some websites with https protocols.
Users that tried to help me reported that it works from OSX and linux.
I don't know if this come from QGis or GDAL (or even curl?)

Links example :
Works well -> /vsizip//vsicurl/http://bano.openstreetmap.fr/BAN_odbl/BAN_odbl_01-shp.zip
Don't work -> /vsizip//vsicurl/https://cadastre.data.gouv.fr/data/etalab-cadastre/latest/shp/departements/01/cadastre-01-parcelles-shp.zip

Tested on 2.18.23 and 3.4.2, same behaviour.


Related issues

Duplicates QGIS Application - Bug report #19331: GDAL/VSICURL certificate errors loading cloud optimized g... Open 2018-07-04

History

#1 Updated by Giovanni Manghi about 1 year ago

  • Category changed from GDAL Tools to Data Provider
  • Status changed from Open to Feedback

What about windows 10?

#2 Updated by Chris Chauvot about 1 year ago

I don't know, I don't have this distrib at my disposal, and my department doesn't plan to migrate all their computers to W10 soon.
I fixed it but unfortunately it didn't lasted long.

The problem comes from CURL, which needs a certificate if it isn't built with the libraries of the OS, which isn't the case with QGIS on Windows. As the http protocol don't need this certificate, it works well.

Then, Is it possible to change the way CURL is built? Or provide the certificate during the installation? Deactivate the SSL verification within OGR and GDAL is also possible, but less secure.

See my post on GIS stack exchange for further info : https://gis.stackexchange.com/questions/304912/cant-open-specific-layers-with-qgis-nor-ogr/305176

#3 Updated by Giovanni Manghi about 1 year ago

The problem comes from CURL, which needs a certificate if it isn't built with the libraries of the OS, which isn't the case with QGIS on Windows. As the http protocol don't need this certificate, it works well.

Then, Is it possible to change the way CURL is built? Or provide the certificate during the installation?

this would be a feature request, don't you agree?

#4 Updated by Chris Chauvot about 1 year ago

Sounds more like a fix as it is intended that https datasources works as demonstrated in the docs/cookbook.
Also I'm not 100% sure the certificate is the only cause, I think this requires more investigation.

#5 Updated by Giovanni Manghi about 1 year ago

Chris Chauvot wrote:

Sounds more like a fix as it is intended that https datasources works as demonstrated in the docs/cookbook.
Also I'm not 100% sure the certificate is the only cause, I think this requires more investigation.

it is an operating system thing, not a qgis one. I don't think is a bug.

#6 Updated by Chris Chauvot 12 months ago

Well, it's not that simple.

The problem doesn't comes from Windows itself, but from the way CURL is built.
Windows doesn't fail to provide certificates, CURL just doesn't use them.

The problem definitely comes from a specificity of CURL, but it depends on the way it is installed. Then, as CURL comes preinstalled on the dedicated python environment of QGIS, the problem should be handled by QGIS, or at least specified on the documentation.

Also, seems to be a duplicate of #19331

#7 Updated by Giovanni Manghi 10 months ago

  • Duplicates Bug report #19331: GDAL/VSICURL certificate errors loading cloud optimized geotiffs over https via data source manager added

#8 Updated by Giovanni Manghi 10 months ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Also available in: Atom PDF