Bug report #2067

Segmentation error on opening a project

Added by Patrice Vetsel - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Project Loading/Saving
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12127

Description

I use qgis 1.3.0 on a clean and fresh installation of Ubuntu 9.10 amd64
I open some layers
Save the project

-> but on opening this project qgis crash

I attach my project file

Anduze.qgs - The project file saved by qgis but can't be re-opened (18.3 KB) Patrice Vetsel -, 2009-11-08 06:49 AM

History

#1 Updated by Martin Dobias almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in 61d45be9 (SVN r12042).

This actually just prevents creation of new project files that would cause segfaults. Opening OSM layers from project files with custom renderer will not work in near future because the renderer is assigned by a python plugin and it's not available when loading project file.

Also available in: Atom PDF