Bug report #20640

User Profiles Menu interface customization

Added by Hanif Rifai almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Customisation Framework
Affected QGIS version:3.4.1 Regression?:No
Operating System: Easy fix?:Yes
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:28460

Description

Interface customization does not apply to User Profiles Menu (under mSettingsMenu) and its children because the object name is not set.
QgisApp::refreshProfileMenu [[https://github.com/qgis/QGIS/blob/6cc41a947418cf7e96c8c8c70833435b880a7634/src/app/qgisapp.cpp#L2558]]
QgisApp::createProfileMenu [[https://github.com/qgis/QGIS/blob/6cc41a947418cf7e96c8c8c70833435b880a7634/src/app/qgisapp.cpp#L2601]]

0002-set-user-profile-menu-object-name.patch Magnifier (1.68 KB) Hanif Rifai, 2018-11-27 12:32 PM

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

Please submit the path as Pull Request on GitHub, here it won't be reviewed.

#2 Updated by Hanif Rifai almost 2 years ago

Giovanni Manghi wrote:

Please submit the path as Pull Request on GitHub, here it won't be reviewed.

Ok

#3 Updated by Harrissou Santanna over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Fixed in a6d23449

Also available in: Atom PDF