Bug report #2055

OSM plugin: incorrect BBOX values used on data download

Added by Dan Karran almost 11 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:12115

Description

If you open layers in QGIS that aren't in WGS84 (e.g. I tried with some GeoTIFFs in OSGB36) and then try to download data from OSM to overlay, the BBOX uses the coordinates from the original CRS not WGS84 as is needed. Can that be forced to use WGS84 to make sure it'll work with OSM?

History

#1 Updated by Martin Dobias over 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

OSM plugin transforms the extent, but you have to enable projections to have it working. Because otherwise the plugin can't tell what's the reference system of the project and thus can't do the transformation.

Also available in: Atom PDF