Bug report #2050

Symbology -> Unique Value doesn't work with POSTGIS point layer

Added by luca76 - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:12110

Description

Tested on QGIS 1.3.0 and trunk r11922

steps to reproduce:

1) open a POSTGIS point layer
2) open layer properties -> symbology -> choose Unique Value
3) select a text field (mine is a 1 char with 4 values)
4) click OK

you see all points with one color (the default value). Deleting the default value results in an empty map.

History

#1 Updated by Giovanni Manghi almost 10 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

works for me under both linux and windows with qgis-trunk. Reopen if necessary.

Also available in: Atom PDF