Bug report #20460

Embedding layers does not work for projects saved as QGZ

Added by A. Egberts almost 2 years ago. Updated over 1 year ago.

Status:Open
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:3.7(master) Regression?:No
Operating System:Windows 10 Qgis 3.4.1 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28280

Description

I try to embed a layer from a QGS file made in Qgis 3.14. layer is not loading, or not shown.
When I try to embed the same layer form a QGS file made with 2.18, I get that layer well!

What is going wrong?

Knipsel.JPG (36.1 KB) A. Egberts, 2018-11-12 09:25 AM

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Category changed from Virtual Layers to Project Loading/Saving
  • Status changed from Open to Feedback

what if you save the QGIS 3 project as qgs and not as qgz?

#2 Updated by A. Egberts almost 2 years ago

Giovanni Manghi wrote:

what if you save the QGIS 3 project as qgs and not as qgz?

Yes thats a work arround! But if I want to add a layer form a older qgz file, I can choose it, but not add it!

#3 Updated by Giovanni Manghi almost 2 years ago

  • Subject changed from Embedding layers in qgis 3.4.1 form version 3 is not working, from version 2 is working! to Embedding layers does not work for projects saved as QGZ
  • Priority changed from High to Normal
  • Status changed from Feedback to Open

#4 Updated by matteo ghetta over 1 year ago

  • Affected QGIS version changed from 3.4.1 to 3.7(master)

confirmed also on 3.7: not working with qgz, working with qgs. If there is not a simple fix, what about adding a warning message in the meanwhile?

Also available in: Atom PDF