Bug report #2044

Field Calculator Problem

Added by Marco Hugentobler about 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12104

Description

Hi all,

I've come across a problem with the field calculator. I'm using QGIS
1.4.0.39 via OSGEO4W on an XP box. Here's the issue:

When using field calculator to "Only Update Selected Features," all
unselected features (incorrectly) get a value filled. For example, if I
create a new field, and set it equal to an existing field, the selected
features get updated properly. However, all other features get the value of
the first selected feature.

History

#1 Updated by Marco Hugentobler about 11 years ago

As soon as I commit the changes to disk, the values seem to be normal again. Also the identify tool shows correct results. Probably an issue with the attribute table and not-commited values.

#2 Updated by Marco Hugentobler almost 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

attribute table update seems to be fixed in 7f067126 (SVN r12556). Thanks, jef!

Also available in: Atom PDF