Bug report #20431

no possibility to confirm in the attribut form while add more than one feature (postgres)

Added by Jan Lippmann over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:3.4.1 Regression?:Yes
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28251

Description

Important: it happens only when "evaluate default values on provider side" is deactivated in the project settings

if i hide the id field, i can confirm the form for more than one feature without saving.

3.4.1 also affected

add_save.gif (1.35 MB) Jan Lippmann, 2018-11-09 10:09 PM


Related issues

Related to QGIS Application - Bug report #20523: Adding new features in postgis fails with attribute windo... Closed 2018-11-17
Related to QGIS Application - Bug report #20397: QGIS 3.4 Incorrect handling of Postgres serial columns Closed 2018-11-07

Associated revisions

Revision 32b7d7e5
Added by David Signer over 1 year ago

check uniqueCheck before overwrite defaultValueClause

and some tests for it
this fixes #20397 and fixes #20431

Revision 76667eee
Added by David Signer over 1 year ago

check uniqueCheck before overwrite defaultValueClause

and some tests for it
this fixes #20397 and fixes #20431

(cherry-picked from 32b7d7e5ddeef7a66592267819e234085c44a7bc)

History

#1 Updated by Harrissou Santanna over 1 year ago

  • Operating System changed from Win 7 64bit to Windows
  • Regression? changed from No to Yes

I can also confirm, on a Windows 10 (though not sure it's related).
A regression imho. An opt-in option should not block this important feature.

#2 Updated by Harrissou Santanna over 1 year ago

  • Affected QGIS version changed from 3.5(master) to 3.4.1

#3 Updated by Harrissou Santanna over 1 year ago

  • Related to Bug report #20523: Adding new features in postgis fails with attribute window popup added

#4 Updated by Harrissou Santanna over 1 year ago

  • Related to Bug report #20397: QGIS 3.4 Incorrect handling of Postgres serial columns added

#5 Updated by David Signer over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF