Bug report #2043

Merging multi-polygon-features on PostGIS fails

Added by fritz123 - about 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12103

Description

QGIS 1.3.0 can't merge features as described below:

"The union operation would result in a geometry type that is not compatible with the current layer and therefore is canceled"

Imagine a PostGIS-geometry-table, using the type multipolygon. Some of the features therein have islands, others don't. If you try to merge two features without islands, the resulting feature is type polygon. This also happens, when you try it manually using st_union. Since there is a constraint on the geometry column, the resulting feature can't be inserted. Using st_multi helps on database level.

PostGIS-Version is 1.3.6.

History

#1 Updated by Giovanni Manghi almost 11 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

I believe that this ha been already fiexed. Nevertheless after merging qgis returns the error reported in #2187.

Also available in: Atom PDF