Bug report #20425

Advanced editing issue in QGIS 3.4.1

Added by Giovanni Zanoni almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:3.4.1 Regression?:No
Operating System:windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:28245

Description

Hi all,
during editing session when I use 'advanced digitizing tools' and snap is active, when I begin to digitize QGIS starts loading and I have to force closure. Actually it doesn't crash.
QGIS 3.2 is ok

qgis341.png - qgis error (104 KB) Giovanni Zanoni, 2018-11-12 11:59 AM

sez1.cpg (5 Bytes) Giovanni Zanoni, 2018-11-12 12:17 PM

error.qgz (3.55 KB) Giovanni Zanoni, 2018-11-12 12:17 PM

sez1.dbf (189 Bytes) Giovanni Zanoni, 2018-11-12 12:17 PM

sez1.prj (398 Bytes) Giovanni Zanoni, 2018-11-12 12:17 PM

sez1.shp (188 Bytes) Giovanni Zanoni, 2018-11-12 12:17 PM

sez1.qpj (652 Bytes) Giovanni Zanoni, 2018-11-12 12:17 PM

sez1.shx (108 Bytes) Giovanni Zanoni, 2018-11-12 12:17 PM

bug1.zip - Sample project with my default profile (5.15 KB) Sigrid Lynaes, 2018-11-29 12:06 PM

bug.zip - Sample project with clean profile (4.84 KB) Sigrid Lynaes, 2018-11-29 12:07 PM

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to High
  • Crashes QGIS or corrupts data changed from No to Yes

Please attach a sample project with data and exact steps to follow.

#2 Updated by Giovanni Zanoni almost 2 years ago

I try to explain step by step what happens:
1) I activate SNAP option
2) I activate 'adavaned digitising'
3) I starts digitising on an exiting layer so SNAP 'attach' my new feature to an exiting one
4) QGIS starts loading with no end as you can see in the attached picture
5) I force closure

#3 Updated by Giovanni Manghi almost 2 years ago

GIOVANNI ZANONI wrote:

I try to explain step by step what happens:
1) I activate SNAP option
2) I activate 'adavaned digitising'
3) I starts digitising on an exiting layer so SNAP 'attach' my new feature to an exiting one
4) QGIS starts loading with no end as you can see in the attached picture
5) I force closure

please add a sample project with data.

#4 Updated by Giovanni Zanoni almost 2 years ago

As the error is in every project here a sample

#5 Updated by Giovanni Manghi almost 2 years ago

GIOVANNI ZANONI wrote:

I try to explain step by step what happens:
1) I activate SNAP option
2) I activate 'adavaned digitising'
3) I starts digitising on an exiting layer so SNAP 'attach' my new feature to an exiting one
4) QGIS starts loading with no end as you can see in the attached picture
5) I force closure

I cannot replicate here. Try with a new/clean profile.

#6 Updated by Giovanni Zanoni almost 2 years ago

Sorry, do you mean a new bug report?

#7 Updated by Giovanni Manghi almost 2 years ago

GIOVANNI ZANONI wrote:

Sorry, do you mean a new bug report?

no, try if you can replicate using a new profile

settings > user profiles > new profile

#8 Updated by Sigrid Lynaes almost 2 years ago

Giovanni Manghi wrote:

GIOVANNI ZANONI wrote:

Sorry, do you mean a new bug report?

no, try if you can replicate using a new profile

settings > user profiles > new profile

I have a very similar problem/experience:
I've attached a sample project, where I'm using my default profile. (called bug1.zip)
In the project I have 'advanced digitizing'-button active.
When I push the 'snap' button, Q-GIS freezes up (QGIS is not responding), and I have to force quit. The problem both occurs in QGIS 3.4.1 and 3.4.2.

When I tried Q-GIS 3.4.2 with a clean profile, the problem is different. I don't get the opportunity to activate advanced digitizing. I can't figure out why. (attached sample project called bug.zip)

My operating system is Windows 10 Pro.

Are you able to replicate the error with my sample project?

#9 Updated by Giovanni Manghi almost 2 years ago

When I tried Q-GIS 3.4.2 with a clean profile, the problem is different. I don't get the opportunity to activate advanced digitizing. I can't figure out why. (attached sample project called bug.zip)

My operating system is Windows 10 Pro.

Are you able to replicate the error with my sample project?

no, is all ok on 3.4.2 here. No 3rd party plugins installed.

#10 Updated by Sigrid Lynaes almost 2 years ago

no, is all ok on 3.4.2 here. No 3rd party plugins installed.

I uninstalled all 3rd party plugins and restarted the computer before creating the projects above.
I might look further into why advanced digitizing cannot activate when I'm using a clean profile. I'll let you know, if I discover anything.

#11 Updated by Giovanni Zanoni almost 2 years ago

I solved the issue creating a clean profile (settings-->user profiles). The issue seems to relate to a 3rd party plugin which doesn't create problems in 3.2 version

#12 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

Also available in: Atom PDF