Bug report #20367

"avoid intesection" cannot be enabled without activating snapping

Added by Antonio Viscomi about 1 year ago. Updated about 1 year ago.

Status:Open
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:3.4.1 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28187

Description

New description:

Subject says it all. This is NOT the case in 2.18.

Old description:

Hi all,
I noticed this bug:
- activate advanced snapping configuration enabling "Avoid Intersection" option on two layers;
- then I deactivate snap on one of two layers (but "Avoid Intersection" flag was not syncronized with layer flag);
- I tried to create a new polygon in my feature, but editing came out with error (geometry is collapsed);
- then I deactivated "Avoid Intersection" from unflagged layer;
- I created the new geometry and all works fine.

I attach a screencast that show this

Avoid_Intersections.mp4 (1.75 MB) Antonio Viscomi, 2018-11-05 02:45 PM

Avoid Intersections.png (176 KB) Antonio Viscomi, 2018-11-05 05:12 PM

History

#1 Updated by Antonio Viscomi about 1 year ago

3.4.1 and 15b2352ea2 versions are affected

#2 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

Did you tagged as a regression because a previous version worked as expected?

#3 Updated by Antonio Viscomi about 1 year ago

Giovanni Manghi wrote:

Did you tagged as a regression because a previous version worked as expected?

Sorry
i tagged regression by mistake
it appear also in 2.18.25

#4 Updated by Antonio Viscomi about 1 year ago

Antonio Viscomi wrote:

Giovanni Manghi wrote:

Did you tagged as a regression because a previous version worked as expected?

Sorry
i tagged regression by mistake
it appears also in 2.18.25

in screenshot appears the same bug...
the Avoid Intersections flag is active on the layer on which the snap is not active (and create a polygon don't ignore it)

#5 Updated by Giovanni Manghi about 1 year ago

  • Regression? changed from Yes to No
  • Status changed from Feedback to Open
  • Operating System deleted (windows 7 x64)

#6 Updated by Rob Willson about 1 year ago

sorry if I'm not understanding this correctly but I think this would be be the correct behaviour. I often want to have avoid intersection work for a layer but have snapping for that layer turned off.

I admit it would be nice if you could still check the box to turn off avoid intersections without having to turn snapping back on for that layer.

#7 Updated by Antonio Viscomi about 1 year ago

Rob Willson wrote:

sorry if I'm not understanding this correctly but I think this would be be the correct behaviour. I often want to have avoid intersection work for a layer but have snapping for that layer turned off.

I admit it would be nice if you could still check the box to turn off avoid intersections without having to turn snapping back on for that layer.

Sorry but,
how could work avoid intersections if the snap is disabled for that layer?

The problem is that the flag on avoid intersection related to the layer with the snap disabled, prevents the creation of a new feature in the layer where the snap is active

Then I suggest that the correct behavior should be one of the following two:

1- the editing tools should ignore all snapping setting for a layer with snap unchecked;

2-alternatively, the check for avoid intersections should automatically disable when the snap related to that layer is turned off

#8 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback

I also think that there is no issue here. The "avoid intersection" flag is not directly related with the other that enables snapping for a layer.

As it works for snapping also the "avoid intersection" property works among different layers.

If I'm not wrong this is how it worked also on 2.*.

#9 Updated by Antonio Viscomi about 1 year ago

Giovanni Manghi wrote:

I also think that there is no issue here. The "avoid intersection" flag is not directly related with the other that enables snapping for a layer.

As it works for snapping also the "avoid intersection" property works among different layers.

If I'm not wrong this is how it worked also on 2.*.

But "avoid intersection" is or not related to the snapping option of a layer?
Well
- if is related it should follow the snapping check for each layer;
- if is not sorry for my misunderstanding

#10 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

But "avoid intersection" is or not related to the snapping option of a layer?

no, is not related. As you can see you can avoid intersections even if snapping is not enabled.

#11 Updated by Antonio Viscomi about 1 year ago

Giovanni Manghi wrote:

But "avoid intersection" is or not related to the snapping option of a layer?

no, is not related. As you can see you can avoid intersections even if snapping is not enabled.

This is no real in 3.4.1 and Master...
If you don't previously flag the snap check for a layer
Avoid intersections is not selectable

Seeing is believing

#12 Updated by Giovanni Manghi about 1 year ago

  • Priority changed from Normal to High
  • Resolution deleted (invalid)
  • Regression? changed from No to Yes
  • Subject changed from Avoid intersection don't works in 3.4 to "avoid intesection" cannot be enabled without activating snapping
  • Description updated (diff)
  • Status changed from Closed to Open

«

This is no real in 3.4.1 and Master...
If you don't previously flag the snap check for a layer
Avoid intersections is not selectable

Seeing is believing

subject and description updated.

Also available in: Atom PDF