Bug report #20263

GDAL "Extract projection" not available from the processing toolbox in 3.4

Added by Håvard Tveite over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Processing/GDAL
Affected QGIS version:3.4.0 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28084

Description

The GDAL "Extract projection" algorithm used to be available under [GDAL]-> Projections in the processing toolbox in QGIS 2.
Expected to be available under GDAL-> Raster projections in QGIS 3, but it is not in my 3.4 on Ubuntu 18.04.
The algorithm is still available as "extractprojection.py" in QGIS/python/plugins/processing/algs/gdal, and looks OK to me.
It seems to be the only missing GDAL algorithms in QGIS 3.4 compared to QGIS 2.18 here.

Associated revisions

Revision 296df2e0
Added by Håvard Tveite over 1 year ago

Reintroduce GDAL extract projection

Fixes #20263 (when some other files are also fixed)

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Regression? changed from No to Yes
  • Priority changed from Normal to High
  • Operating System deleted (Ubuntu 18.04)

#2 Updated by Håvard Tveite over 1 year ago

I checked the code (extractprojection.py), and found that it had not been completely adapted to QGIS 3.
I tried to fix it, but got stuck when I found that GetGeoTransform() is no longer available
in QgsRasterLayer. The result of GetGeoTransform is used directly to create the world file.
In QGIS 3 GetGeoTransform seems only to be available for gdal datasources.
Using the source returned from gdal.Open works. I may be able to create a pull request.

#4 Updated by Giovanni Manghi over 1 year ago

  • Pull Request or Patch supplied changed from No to Yes

#5 Updated by Håvard Tveite over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF