Bug report #2026

Oracle connection fails

Added by HansV - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12086

Description

Connection to Oracle fails.
Dialog: "Create a New OGR Database connection"
I entered Host, Database, Port, Username and Password

Then "Test connection" replies:

ORA-12154: TNS:could not resolve the connect identifier specified in <unnamed>

And after hitting the OK button:

Invalid Data Source
OCI:Username/[email protected]/Database is not a valid or recognized data source

Even when I leave Host empty, I get an error because the slash is still in front of Database.
What are the steps to make the Oracle connection work?

Associated revisions

Revision 2700a3d0
Added by Jürgen Fischer over 10 years ago

fix #2026

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision c3942d49
Added by Jürgen Fischer over 10 years ago

fix #2026

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF