Bug report #20206

issues on vertex selection with the new "edit vertex tool" in QGIS Master

Added by Antonio Viscomi almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:28027

Description

Hi,
vertex editor don't hook the polygon boundary

I attach 3 screencast that show this issues:
- the first (vertex_1) show how is difficult (sometime impossible) to hook right a polygon you want to edit;
- I need to edit polygon 65592 but it is impossible to hook it without move a vertex of 65600;
- once the 65600 vertex has been moved it is possible to hook 65592. but 65600 it becomes unchallengeable (as shown in vertex_2);

the 3th one screencast show how easy it is to perform the same selection using QGIS 2

Regards

vertex_1.fbr (3.64 MB) Antonio Viscomi, 2018-10-24 01:19 PM

vertex_2.fbr (4.17 MB) Antonio Viscomi, 2018-10-24 01:19 PM

vertex_QG2.fbr (1.55 MB) Antonio Viscomi, 2018-10-24 01:19 PM

vertex_2.avi (1.27 MB) Antonio Viscomi, 2018-10-24 01:23 PM

vertex_1.avi (1.47 MB) Antonio Viscomi, 2018-10-24 01:23 PM

vertex_QG2.avi (1.02 MB) Antonio Viscomi, 2018-10-24 01:23 PM

Data_VE.7z.002 (4.75 MB) Antonio Viscomi, 2018-10-24 01:30 PM

Data_VE.7z.001 (5 MB) Antonio Viscomi, 2018-10-24 01:30 PM

Project vertex.qgz (4.62 KB) Antonio Viscomi, 2018-10-24 02:22 PM

Project vertex.qgz (4.83 KB) Antonio Viscomi, 2018-10-24 03:21 PM

History

#1 Updated by Antonio Viscomi almost 2 years ago

Antonio Viscomi wrote:

Hi,
vertex editor don't hook the polygon boundary

I attach 3 screencast that show this issues:
- the first (vertex_1) show how is difficult (sometime impossible) to hook right a polygon you want to edit;
- I need to edit polygon 65592 but it is impossible to hook it without move a vertex of 65600;
- once the 65600 vertex has been moved it is possible to hook 65592. but 65600 it becomes unchallengeable (as shown in vertex_2);

the 3th one screencast show how easy it is to perform the same selection using QGIS 2

Regards

.avi screencasts

#2 Updated by Antonio Viscomi almost 2 years ago

Antonio Viscomi wrote:

Antonio Viscomi wrote:

Hi,
vertex editor don't hook the polygon boundary

I attach 3 screencast that show this issues:
- the first (vertex_1) show how is difficult (sometime impossible) to hook right a polygon you want to edit;
- I need to edit polygon 65592 but it is impossible to hook it without move a vertex of 65600;
- once the 65600 vertex has been moved it is possible to hook 65592. but 65600 it becomes unchallengeable (as shown in vertex_2);

data

the 3th one screencast show how easy it is to perform the same selection using QGIS 2

Regards

.avi screencasts

#3 Updated by Giovanni Manghi almost 2 years ago

  • Category changed from Editing to Digitising

I struggle to understand the problem even after having watched the screencasts.
Attaching a project with data possibly could help.

#4 Updated by Antonio Viscomi almost 2 years ago

Giovanni Manghi wrote:

I struggle to understand the problem even after having watched the screencasts.
Attaching a project with data possibly could help.

the data are already attached

the problem is: How I can edit the vertex of 65592 in I don't touch his vertex?

I hope this hel you

#5 Updated by Antonio Viscomi almost 2 years ago

Antonio Viscomi wrote:

Giovanni Manghi wrote:

I struggle to understand the problem even after having watched the screencasts.
Attaching a project with data possibly could help.

the data are already attached

the problem is: How I can edit the vertex of 65592 if I don't be able to touch his vertex?

I hope this help you

#6 Updated by Giovanni Manghi almost 2 years ago

the data are already attached

opening the project asks for a layer that maybe was not attached here (or maybe was attached in a format I cannot open: fbr? 001? 002?).

#7 Updated by Antonio Viscomi almost 2 years ago

Giovanni Manghi wrote:

the data are already attached

opening the project asks for a layer that maybe was not attached here (or maybe was attached in a format I cannot open: fbr? 001? 002?).

The layer is in .7z (001 and 002) because too large (about 9MB)

#8 Updated by Antonio Viscomi almost 2 years ago

Antonio Viscomi wrote:

Giovanni Manghi wrote:

the data are already attached

opening the project asks for a layer that maybe was not attached here (or maybe was attached in a format I cannot open: fbr? 001? 002?).

The layer is in .7z (001 and 002) because too large (about 9MB)

.7z are 7zip files

#9 Updated by Giovanni Manghi almost 2 years ago

Antonio Viscomi wrote:

Antonio Viscomi wrote:

Giovanni Manghi wrote:

the data are already attached

opening the project asks for a layer that maybe was not attached here (or maybe was attached in a format I cannot open: fbr? 001? 002?).

The layer is in .7z (001 and 002) because too large (about 9MB)

.7z are 7zip files

the project you attached ask for a layer that is not in that zip file.

#10 Updated by Antonio Viscomi almost 2 years ago

Giovanni Manghi wrote:

Antonio Viscomi wrote:

Antonio Viscomi wrote:

Giovanni Manghi wrote:

the data are already attached

opening the project asks for a layer that maybe was not attached here (or maybe was attached in a format I cannot open: fbr? 001? 002?).

The layer is in .7z (001 and 002) because too large (about 9MB)

.7z are 7zip files

the project you attached ask for a layer that is not in that zip file.

However the labels in screencasta are FID of data file I attached

#11 Updated by Antonio Viscomi almost 2 years ago

Antonio Viscomi wrote:

Giovanni Manghi wrote:

Antonio Viscomi wrote:

Antonio Viscomi wrote:

Giovanni Manghi wrote:

the data are already attached

opening the project asks for a layer that maybe was not attached here (or maybe was attached in a format I cannot open: fbr? 001? 002?).

The layer is in .7z (001 and 002) because too large (about 9MB)

.7z are 7zip files

the project you attached ask for a layer that is not in that zip file.

However the labels in screencasta are FID of data file I attached

this project ask for correct shapefile

sorry

#12 Updated by Antonio Viscomi almost 2 years ago

I try to summarise:
1 - I starded editing_
2 - I move the mouse on polygon 65592 to edit his vertex;
3 - vertex editor was able to select all other feature except 65592 or 28478:
4 - I zoomed in to try to hook the vertex of 65592 but oly 65600 vertex were selectable:
5 - I moved out a vertex of 65600 (reshaping it) then I became able to edit 65592;
6 - after these operations the vertex of 65600 have become unselectable

I hope it's clearer now

#13 Updated by Giovanni Manghi almost 2 years ago

  • Regression? changed from Yes to No
  • Status changed from Open to Feedback
  • Priority changed from High to Normal

Antonio Viscomi wrote:

I try to summarise:
1 - I starded editing_
2 - I move the mouse on polygon 65592 to edit his vertex;
3 - vertex editor was able to select all other feature except 65592 or 28478:
4 - I zoomed in to try to hook the vertex of 65592 but oly 65600 vertex were selectable:
5 - I moved out a vertex of 65600 (reshaping it) then I became able to edit 65592;
6 - after these operations the vertex of 65600 have become unselectable

I see what you say, but anyway this is "solved" by first selecting (with the selection tool) the polygon you want to edit. This may be very well something that was implemented by design. You should ask in the users/developers mailing lists, once you get a clear answer we can escalate (or close) this ticket.

#14 Updated by Antonio Viscomi almost 2 years ago

Giovanni Manghi wrote:

Antonio Viscomi wrote:

I try to summarise:
1 - I starded editing_
2 - I move the mouse on polygon 65592 to edit his vertex;
3 - vertex editor was able to select all other feature except 65592 or 28478:
4 - I zoomed in to try to hook the vertex of 65592 but oly 65600 vertex were selectable:
5 - I moved out a vertex of 65600 (reshaping it) then I became able to edit 65592;
6 - after these operations the vertex of 65600 have become unselectable

I see what you say, but anyway this is "solved" by first selecting (with the selection tool) the polygon you want to edit. This may be very well something that was implemented by design. You should ask in the users/developers mailing lists, once you get a clear answer we can escalate (or close) this ticket.

If it is solved i 3.4 ok I'll try It,
but in older version 3.2.3 an 3.3 this of pre-selection does not works I'd also tried to select the polygon I need to edit (by select tool) but result remain the same

#15 Updated by Giovanni Manghi almost 2 years ago

If it is solved i 3.4 ok I'll try It,
but in older version 3.2.3 an 3.3 this of pre-selection does not works

I'm not saying it is solved, I'm saying that if you pre-select the polygon you want to work on it works.
Try 3.4, all the past versions are not relevant anymore.

#16 Updated by Antonio Viscomi almost 2 years ago

Giovanni Manghi wrote:

If it is solved i 3.4 ok I'll try It,
but in older version 3.2.3 an 3.3 this of pre-selection does not works

I'm not saying it is solved, I'm saying that if you pre-select the polygon you want to work on it works.
Try 3.4, all the past versions are not relevant anymore.

Ok I'll try It

Many thanks

#17 Updated by Antonio Viscomi almost 2 years ago

Antonio Viscomi wrote:

Giovanni Manghi wrote:

If it is solved i 3.4 ok I'll try It,
but in older version 3.2.3 an 3.3 this of pre-selection does not works

I'm not saying it is solved, I'm saying that if you pre-select the polygon you want to work on it works.
Try 3.4, all the past versions are not relevant anymore.

Ok I'll try It

Many thanks

Hi all,
I confirm this ticket can be closed because selection by selection tool, now (in 3.4) make vertex selection able to select vertex

Many thanks

Regards

#18 Updated by Antonio Viscomi almost 2 years ago

Antonio Viscomi wrote:

Antonio Viscomi wrote:

Giovanni Manghi wrote:

If it is solved i 3.4 ok I'll try It,
but in older version 3.2.3 an 3.3 this of pre-selection does not works

I'm not saying it is solved, I'm saying that if you pre-select the polygon you want to work on it works.
Try 3.4, all the past versions are not relevant anymore.

Ok I'll try It

Many thanks

Hi all,
I confirm this ticket can be closed because selection by selection tool, now (in 3.4) make vertex selection able to select vertex

Many thanks

Regards

even if the qgis 2.x mode, ie clicking on the polygon (automatically select vertex) without having to select it in advance, I think was more functional and intuitive

Greetings

#19 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

even if the qgis 2.x mode, ie clicking on the polygon (automatically select vertex) without having to select it in advance, I think was more functional and intuitive

I can't say I don't agree, but please raise your concerns to a wider audience, using the users/developers mailing lists.

#20 Updated by Antonio Viscomi almost 2 years ago

Giovanni Manghi wrote:

even if the qgis 2.x mode, ie clicking on the polygon (automatically select vertex) without having to select it in advance, I think was more functional and intuitive

I can't say I don't agree, but please raise your concerns to a wider audience, using the users/developers mailing lists.

I opened a discussion we'll see

http://osgeo-org.1560.x6.nabble.com/Very-Important-Question-on-vertex-selection-mode-in-QGIS-3-4-tp5383726.html

Regards

Also available in: Atom PDF