Bug report #20172

Adding a new vertex ignore snap on polygon whit self intersection

Added by Antonio Viscomi over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Editing
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:27993

Description

Hi all,
I noticed another issues...
If there are some topological errors,
and I edit the feature to solve them,
in some polygon with self intersection, adding a new vertex on polygon ignore snap settings adding the new vertex anywhere in the shapefile and snapping this vertex to any polygon very far to the poligon I need to edit.
Then this point cause a hole that goes through the entire areal extension of map.

Regards

Antonio

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

It could be me, but I have not understand exactly what the issue is. Can you add detailed step by step operations to follow? Thanks.

#2 Updated by Antonio Viscomi over 1 year ago

Giovanni Manghi wrote:

It could be me, but I have not understand exactly what the issue is. Can you add detailed step by step operations to follow? Thanks.

I need to edit a shapefile with topological error in (self intersections) the steps are:
I try to add a vertex to a polygon with self intersection in;
-the vertex that I need to add don't snap to the neae adjacent polygon but on a far polygon in the same shape;
then the added vertex it will cause a hole that goes through the shapefile;

#3 Updated by Antonio Viscomi over 1 year ago

-I try to add a vertex to a polygon with self intersection in;
-the vertex that I need to add don't snap to the neae adjacent polygon but on a far polygon in the same shape;

why these lines are underlined?

sorry I don't know how explain it better

#4 Updated by Giovanni Manghi over 1 year ago

sorry I don't know how explain it better

make a screencast, thanks.

#5 Updated by Antonio Viscomi over 1 year ago

Giovanni Manghi wrote:

sorry I don't know how explain it better

make a screencast, thanks.

Sorry,
I'm not able to reproduce this issue because I'd solved topological errors in the shapefile on which I noticed the issues appear.
I'll capture a screencast if the issues will appear again on other file
Greetings

#6 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Also available in: Atom PDF