Bug report #20169

Gnome: Open Gdal dialog shows silly long filter list with empty items

Added by Richard Duivenvoorde over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:3.3(master) Regression?:No
Operating System:Debian testing Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27990

Description

See screenshot. I see this only on my Linux machines (both on Debian and Flatpak version).

To reproduce:
- Open Data Source Manager
- Click the Raster item in the right column
- Click the little file chooser button (...)
- Open the 'Filter' dropdown on the bottom.
- With me looks like the screenie

Windows looks fine.

I understand there is also the native vs qt-version of dialogs, not sure if that has something to do with it.

Would be nice if somebody can confirm (for both Gnome and KDE).

Running against Qt 5.11.1

Note that I also have this currently in 2.18, so it could be a Gnome thing.
Running against Qt 4.8.7

toolongFileFilter.png (201 KB) Richard Duivenvoorde, 2018-10-19 05:42 PM

History

#1 Updated by Richard Duivenvoorde over 1 year ago

  • Status changed from Open to Closed

Closing myself, as I found out this is a Gnome typical thing, to be fixed upstream.

You can test it with whatever Gnome/Gtk application with a combobox in it. When you place the combobox on the bottom of your monitor, gtk will try to create the white empty canvas first INSIDE your monitor canvas, and then paint the text on it, and then places little arrows in it to move up or down. But in our case we have so much text that th 'white canvas' itself becomes so big that those arrows will not be visible or working...

Also available in: Atom PDF