Bug report #20090

GeoPackage SQL issues in DB Manager

Added by Antoine Fonoxo over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:3.2.3 Regression?:No
Operating System:Windows 7 64bits Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:27912

Description

DB Manager issues with GPKG geometries on perfectly valid GeoPackage files (made by QGIS or ogr2ogr).
The following SQL queries fail in DB Manager
( but succeed in DB Browser 4 SQLite with EnableGpkgAmphibiousMode ) :

SELECT AsWKT(geom) FROM mypolygon;
--> returns NULL ; should return: MULTIPOLYGON(...

SELECT ST_Area(geom) FROM mypolygon;
--> returns NULL ; should return numeric

SELECT isvalid(geom) FROM mypolygon;
--> returns -1 (which means: UNKNOWN) ; should return 0 or 1

mypolygon.gpkg (132 KB) Antoine Fonoxo, 2018-10-12 04:55 PM


Related issues

Related to QGIS Application - Bug report #18974: No geometry operation on geopackages layers Open 2018-05-17

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

post the dataset plesae.

#2 Updated by Antoine Fonoxo over 1 year ago

SQL queries on geometries failed on every gpkg I tested.
Here is a sample.

I tested the same queries with ogrinfo (bundled with QGIS): no problem with geom functions.

#3 Updated by Giovanni Manghi over 1 year ago

#4 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

duplicate of #18974 (edited)

Also available in: Atom PDF