Bug report #20082

Split Tool "Bursts" linestring when used on complex linestring

Added by Simon Dellis almost 2 years ago. Updated almost 2 years ago.

Status:Open
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:3.4.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:27904

Description

When using the Split tool on a complex linestring (lots of nodes) the linestring "bursts" into many segments. Attached is a sample shapefile that causes the issue and the result after using the split to once.

Simple line strings are not a problem.

Reproduced the problem on versions from 2.18.13 to 3.2.3 on Windows 10 Pro and Enterprise. The same file in Arc splits as expected.

Using the "Split with Lines" tool generates similar problems.

test.zip - Sample shapefile pre-split (429 KB) Simon Dellis, 2018-10-11 09:34 PM

test-split.zip - Sample shapefile post-split (455 KB) Simon Dellis, 2018-10-11 09:53 PM

History

#1 Updated by Saber Razmjooei almost 2 years ago

  • Operating System deleted (Windows 10 Enterprise 64Bit)
  • Category changed from Vectors to Digitising
  • Affected QGIS version changed from 3.2.3 to 3.3(master)

#2 Updated by Giovanni Manghi almost 2 years ago

  • Priority changed from Normal to High

#3 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#4 Updated by Simon Dellis almost 2 years ago

No change in 3.4.1, bug persists.

#5 Updated by Giovanni Manghi almost 2 years ago

  • Affected QGIS version changed from 3.3(master) to 3.4.1
  • Status changed from Feedback to Open

Also available in: Atom PDF