Bug report #20045

Display of more complex attribute forms broken

Added by Andreas Neumann almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:David Signer
Category:Forms
Affected QGIS version:3.3(master) Regression?:Yes
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:27867

Description

In the latest master version the display of more complex forms is totally broken. A lot of information is missing.

Please see attached screenshots that should show the same form: one from QGIS 3.2.x, the other from QGIS master.

Many sections of the form are completely missing.

qgis-complex-form-correct-display-in-qgis-3.2.png - Correct display of form in 3.2.x (102 KB) Andreas Neumann, 2018-10-08 09:56 AM

qgis-complex-form-incorrect-display-in-qgis-3.3.png - Incorrect display of form in 3.3.x (master) (89.4 KB) Andreas Neumann, 2018-10-08 09:56 AM

Associated revisions

Revision f5d2b88d
Added by David Signer almost 2 years ago

check if visibilityexpression is enabled (#8141)

before adding the containers to the mContainerVisibilityInformation

fix: #20045

History

#1 Updated by David Signer almost 2 years ago

  • Assignee set to David Signer

The container-groups are not displayed. I'll investigate on this.

#2 Updated by David Signer almost 2 years ago

I think it's because of an implementation regarding the QML widget I did.

#3 Updated by David Signer almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF