Bug report #1997

Quantum GIS 1.0.2 action causes problem with Konqueror under Kubuntu 8.04

Added by Dan1 - about 11 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:12057

Description

I installed Quantum GIS 1.0.2 under Kubuntu 8.04 (using Qt 4.3.4).

I downloaded the Alaska example dataset and worked through some of the examples in the Quantum GIS (Version 1.0.0) User Guide.

I tried using example from the User Guide that concerns the Actions Tab that is part of the Vector Properties Dialog (page 40 on). In the example, you use lakes/lakes.gml, select "Layer Properties" and then "Actions." I supplied the following action:

/usr/bin/konqueror http://www.google.com/search?q=%NAMES

When I next called up Konqueror and clicked on ANY non-internal hyperlink (i.e., one for any URL on the Internet), then a Konqueror dialogue box came up that said:

"Open with 'Quantum GIS' "

I was given no choice to decline this option. If I accepted, then QGIS loaded and I get the error message "The layer is not a valid layer and can not be added to the map".

I have since deleted the konqueror/Google-search action from the Actions Tab and rebooted my machine, but clicking on any non-internal URL from Konqueror still produces the behaviour just described.

(Incidentally, I created another QGIS action to do a Google search with Firefox, but that has had no effect on doing a Google search etc from Firefox.)

History

#1 Updated by Giovanni Manghi about 11 years ago

Hi,

please upgrade to 1.3, it was a big jump forward since 1.0.x

I cannot replicate the problem with qgis 1.3 and konqueror under ubuntu 9.04.

Please try reset your konqueror file/mime type association configuration and see if it happens again under qgis 1.3

#2 Updated by Giovanni Manghi about 11 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF