Bug report #1994

Removing a connection from SPIT retains the name

Added by vince - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12054

Description

When I, for example, on the spit dialog, I click on remove to erase a former PostGres connection, it seems to go away all right. But it shows up again the next time I use spit. Same thing if I invoke the import from PostGres dialog.

Associated revisions

Revision 582bf322
Added by Jürgen Fischer almost 10 years ago

fix #1994

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision e117f68d
Added by Jürgen Fischer almost 10 years ago

fix #1994

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Giovanni Manghi almost 10 years ago

Replying to vince:

When I, for example, on the spit dialog, I click on remove to erase a former PostGres connection, it seems to go away all right. But it shows up again the next time I use spit. Same thing if I invoke the import from PostGres dialog.

Actually it retains just the connection name, but the all the rest is correctly gone. If you remove the connection from the "add postgis layer" menu, then it all works fine.

#2 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in e117f68d (SVN r11793).

Also available in: Atom PDF