Bug report #19939

mesh: missing arrows around the edge of the canvas

Added by Mathieu Pellerin - nIRV almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Peter Petrik
Category:Data Provider/MDAL
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27761

Description

As seen in the attached picture (mesh.jpg), mesh layer rendering of vector arrows will sometimes miss arrows along the edge. I assume this is because those fall just, just outside the canvas extent.

IMHO, the requested extent from which arrows are drawn need to be a buffered canvas extent value, possibly canvas extent + maximum lenght of a vector arrow, to insure the rendering is accurate.

(As per discussed on hangout, assigning this to mesh-master Peter)

mesh.jpg (209 KB) Mathieu Pellerin - nIRV, 2018-09-25 02:05 PM

Associated revisions

Revision b0bd6293
Added by Peter Petrik almost 2 years ago

fix #19939: render mesh arrows also on the edge of the canvas

History

#1 Updated by Saber Razmjooei almost 2 years ago

  • Category changed from Vectors to Data Provider/MDAL

#2 Updated by Peter Petrik almost 2 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • Status changed from Open to In Progress

#3 Updated by Peter Petrik almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

#4 Updated by Peter Petrik almost 2 years ago

  • Resolution set to fixed/implemented

fixed in 3.3

Also available in: Atom PDF