Bug report #19796

[osgeo4w] Package: Unknown package opencl.bat exit code 1

Added by Harrissou Santanna about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:27621

Description

Each time I update the nightlies, at the end of the process I get the following message

Package: Unknown package
opencl.bat exit code 1

The first time I updated after opencl insertion, the message was different (do not remember but looked like it found and installed something). Then the next updates always trigger the message above. I tried to unistall it but I got

opencl (2.0.10-3)
KhronosGroup OpenCL runtime
Required by: qgis-dev

setup.log.full (1.8 MB) Harrissou Santanna, 2018-09-10 11:24 AM

setup.log.full - An updated log (4.66 KB) Harrissou Santanna, 2018-09-11 03:15 PM

History

#1 Updated by Jürgen Fischer about 2 years ago

Anything in setup.log(.full)? 32 or 64bit?

#2 Updated by Harrissou Santanna about 2 years ago

Jürgen Fischer wrote:

Anything in setup.log(.full)?

It means? How do I get the info?

32 or 64bit?

64bit

#3 Updated by Jürgen Fischer about 2 years ago

  • Status changed from Open to Feedback

Harrissou Santanna wrote:

Jürgen Fischer wrote:

Anything in setup.log(.full)?

It means? How do I get the info?

%OSGEO4W_ROOT%\var\log

#4 Updated by Harrissou Santanna about 2 years ago

Here's the setup.log.full from this morning. Thanks.

#5 Updated by Jürgen Fischer about 2 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

msvcrt-1.0.3-1 should shed more light on why the opencl.dll update is failing for you.

#6 Updated by Harrissou Santanna about 2 years ago

Updated to the latest osgeo4w, including the new version of msvcrt (btw, no QGIS from yesterday) but still get the message at the end of the process. Relaunching the process afterwards makes no difference. Did I miss something? Should I do anything more?

#7 Updated by Jürgen Fischer about 2 years ago

Harrissou Santanna wrote:

Updated to the latest osgeo4w, including the new version of msvcrt (btw, no QGIS from yesterday) but still get the message at the end of the process. Relaunching the process afterwards makes no difference. Did I miss something? Should I do anything more?

Nothing unexpected. The issue is still there, but the log should have more information now (I'm afraid in french ;))

BTW this is a osgeo4w issue.

#8 Updated by Jürgen Fischer about 2 years ago

Jürgen Fischer wrote:

Harrissou Santanna wrote:

btw, no QGIS from yesterday_

finished just now.

#9 Updated by Harrissou Santanna about 2 years ago

I'm afraid in french ;)

Nothing unguessable. I attached the log file.

#10 Updated by Jürgen Fischer about 2 years ago

Harrissou Santanna wrote:

I'm afraid in french ;)

Nothing unguessable. I attached the log file.

Are you using OSGeo4W's setup (%OSGEO4W_ROOT%\bin\setup.bat) or one downloaded long ago? The "current" one should require admin privileges, which your's apparently lacks.

#11 Updated by Harrissou Santanna about 2 years ago

Are you using OSGeo4W's setup (OSGEO4W_ROOT\bin\setup.bat) or one downloaded long ago? The "current" one should require admin privileges, which your's apparently lacks.

Never ran a setup.bat ;). I have an osgeo4w-setup-x86_64.exe file downloaded in 2013 (is that long enough?) that I run each time I need an update. I might have overlooked but never saw a doc for noobs about osgeo4w usage so continued to use the exe file that worked.

I just run the setup.bat (with the new logo and more repositories) and I got no opencl error. Thanks Jürgen.

Also available in: Atom PDF