Bug report #19776

Copy and Move Feature Error on Geopackage

Added by Michael Knopp about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Editing
Affected QGIS version:3.2.2 Regression?:No
Operating System:Windows 7 Enterprise Service Pack 1 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:27601

Description

When I use the Copy and Move Feature tool on a geopackage it does not create new fid numbers for the copied features. The fid numbers are copied and pasted as the same.

This throws up errors when trying to save.

Commit Errors: (clipped for brevity)

Could not commit changes to layer Commerce Blocks WIP

Errors: ERROR: 13 feature(s) not added.

  Provider errors:
      OGR error creating feature -68: failed to execute insert : UNIQUE constraint failed: Commerce Blocks WIP.fid

If I manually go into the table and change the fid numbers to unused numbers it will save just fine.

This does not happen with a copy / paste procedure then a move.


Related issues

Related to QGIS Application - Bug report #19130: 'Move and Copy' feature of vector editor duplicates 'fid' Closed 2018-06-07

History

#1 Updated by Jérôme Guélat about 2 years ago

See also #19130

#2 Updated by Jürgen Fischer about 2 years ago

  • Related to Bug report #19130: 'Move and Copy' feature of vector editor duplicates 'fid' added

#3 Updated by Giovanni Manghi about 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF