Bug report #19711

[Processing] Distance units drop-down is reset after each execution

Added by Harrissou Santanna over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GUI
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:27536

Description

Open an algorithm that uses a distance parameter, with the drop-down units widget (let's say for example "line substring")
Fill the values and change the current units to another one
Run the algorithm
Enable the Parameters tab (in my case I disabled the algorithm closure after execution), you'll see that the units comboboxes are reset to their initial value.
Because they are the only parameters that change in the dialog, and I think user does not expect this, the previously set (and run) unit should be kept (for further trials).

History

#1 Updated by Harrissou Santanna over 1 year ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

Doing some further tests, I'm unable to reproduce. Wionder if i inadvertently switch layers but i'm not sure.
Closing for now but i'm pretty sure that I did not dream it. Will investigate.

Also available in: Atom PDF