Bug report #19662

Scale of scalebar in print composer is wrong.

Added by YiJie Wu almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.2.2 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:27487

Description

The scale of scalebar is about 100 times the actual scale.

I have only 1 map item in that layout. The scalebar unit I selected is "Kilometers".

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

please attach a sample project with the layout and sample data.

#2 Updated by YiJie Wu almost 2 years ago

Hi Giovanni Manghi,

I am very sorry...
I found out that the error occurred because I set the CRS to EPSG:3857.

The detailed explanation is here:
https://gis.stackexchange.com/questions/217306/qgis-print-composer-scale-problems

Sorry again!

#3 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF