Bug report #1965

qgis crashes after start

Added by torstenosgeo - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:12025

Description

Package: qgis
Version: 1.3.0~gfossit20090914-1
Severity: important

Hallo,
qgis crashes after start. On the console I get the following messeges:
qgis
/usr/bin/qgis.bin: /usr/lib/libidn.so.11: no version information available (required by /usr/lib/libcurl-gnutls.so.4)
Python support ENABLED :-)
Loaded : Click-fu (package: clickfu)
Loaded : Geocoding (package: GeoCoding)
Loaded : Geoprocessing (package: geoprocessing)
Loaded : MapSheetAutoGeoRef (package: MapSheetAutoGeoRef)
Loaded : OpenStreetMap plugin (package: osm_loader)
Loaded : Plugin Installer (package: plugin_installer)
Loaded : qgsAffine (package: qgsAffine)
SUB marker line 1
Loaded : Symbology-NG (package: symbology_ng)
Loaded : Table Manager (package: tablemanager)
Warning: Loading a file that was saved with an older version of qgis (saved in 1.1.0-Pan (Unstable), loaded in 1.3.0-Mimas). Problems may occur.
Debug: QGIS/ KIconCache::Private::themeDirsChanged: Theme directory has been modified
Warning: QPainter::end: Painter not active, aborted
Warning: QPainter::begin: Cannot paint on a null pixmap
Warning: QPainter::setPen: Painter not active
Warning: QPainter::setFont: Painter not active
Warning: QPainter::end: Painter not active, aborted
Warning: QPixmap::scaled: Pixmap is a null pixmap
terminate called after throwing an instance of 'QgsGrass::Exception'
what(): Incompatible library version for module. You need to rebuild GRASS or untangle multiple installations.
Abgebrochen (Speicherabzug geschrieben)

$ qgis
/usr/bin/qgis.bin: /usr/lib/libidn.so.11: no version information available (required by /usr/lib/libcurl-gnutls.so.4)
Python support ENABLED :-)
Loaded : Click-fu (package: clickfu)
Loaded : Geocoding (package: GeoCoding)
Loaded : Geoprocessing (package: geoprocessing)
Loaded : MapSheetAutoGeoRef (package: MapSheetAutoGeoRef)
Loaded : OpenStreetMap plugin (package: osm_loader)
Loaded : Plugin Installer (package: plugin_installer)
Loaded : qgsAffine (package: qgsAffine)
SUB marker line 1
Loaded : Symbology-NG (package: symbology_ng)
Loaded : Table Manager (package: tablemanager)
Warning: QMetaObject::connectSlotsByName: No matching signal for on_btnHelp_clicked()
ERROR 4: @/home/torsten/Arbeit/Gis/FoEi/tk/4367059_5677239_col.tfw' not recognised as a supported file format.

Warning: QPainter::end: Painter not active, aborted
Warning: QPainter::begin: Cannot paint on a null pixmap
Warning: QPainter::setPen: Painter not active
Warning: QPainter::setFont: Painter not active
Warning: QPainter::end: Painter not active, aborted
Warning: QPixmap::scaled: Pixmap is a null pixmap
qgis.bin: /usr/src/qgis/i386/1.3.0~gfossit20090914/qgis-1.3.0~gfossit20090914/src/app/qgsoptions.cpp:575: void QgsOptions::getEllipsoidList(): Zusicherung »myResult 0« nicht erfüllt.
Abgebrochen (Speicherabzug geschrieben)

$ qgis
/usr/bin/qgis.bin: /usr/lib/libidn.so.11: no version information available (required by /usr/lib/libcurl-gnutls.so.4)
Python support ENABLED :-)
Loaded : Click-fu (package: clickfu)
Loaded : Geocoding (package: GeoCoding)
Loaded : Geoprocessing (package: geoprocessing)
Loaded : MapSheetAutoGeoRef (package: MapSheetAutoGeoRef)
Loaded : OpenStreetMap plugin (package: osm_loader)
Loaded : Plugin Installer (package: plugin_installer)
Loaded : qgsAffine (package: qgsAffine)
SUB marker line 1
Loaded : Symbology-NG (package: symbology_ng)
Loaded : Table Manager (package: tablemanager)
qgis.bin: /usr/src/qgis/i386/1.3.0~gfossit20090914/qgis-1.3.0~gfossit20090914/src/app/qgsoptions.cpp:575: void QgsOptions::getEllipsoidList(): Zusicherung »myResult 0« nicht erfüllt.
Abgebrochen (Speicherabzug geschrieben)

Thanks
Torsten

-- System Information:
Debian Release: squeeze/sid
APT prefers testing
APT policy: (990, 'testing'), (90, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages qgis depends on:
ii libc6 2.9-4 GNU C Library: Shared libraries
ii libexpat1 2.0.1-4 XML parsing C library - runtime li
ii libgcc1 1:4.4.1-1 GCC support library
ii libgdal1-1.5.0 1.5.4-4 Geospatial Data Abstraction Librar
ii libgeos-c1 3.1.0-1 Geometry engine for Geographic Inf
ii libgsl0ldbl 1.12+dfsg-1 GNU Scientific Library (GSL) -- li
ii libpq5 8.4.0-2+b1 PostgreSQL C client library
ii libproj0 4.6.1-5 Cartographic projection library
ii libqgis1.3.0 1.3.0~gfossit20090914-1 Quantum GIS - shared libraries
ii libqt4-network 4:4.5.2-2 Qt 4 network module
ii libqt4-sql 4:4.5.2-2 Qt 4 SQL module
ii libqt4-svg 4:4.5.2-2 Qt 4 SVG module
ii libqt4-xml 4:4.5.2-2 Qt 4 XML module
ii libqtcore4 4:4.5.2-2 Qt 4 core module
ii libqtgui4 4:4.5.2-2 Qt 4 GUI module
ii libstdc++6 4.4.1-1 The GNU Standard C++ Library v3
ii qgis-common 1.3.0~gfossit20090914-1 Quantum GIS - architecture-indepen

Versions of packages qgis recommends:
ii python-qgis 1.1.0~gfossit20090602-1 Python bindings to Quantum GIS
ii qgis-plugin-gras 1.3.0~gfossit20090914-1 GRASS plugin for Quantum GIS

Versions of packages qgis suggests:
ii gpsbabel 1.3.6-3 GPS file conversion plus transfer

History

#1 Updated by Giovanni Manghi almost 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

is this duplicate of #1965? reopen if necessary

#2 Updated by Giovanni Manghi almost 10 years ago

Replying to [comment:1 lutra]:

is this duplicate of #1965? reopen if necessary

I meant #1964

Also available in: Atom PDF