Bug report #19569

QGIS 3.2.1 crashes upon startup when Vectorworks 2018 is installed

Added by Markus Meyer over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:3.2.1 Regression?:No
Operating System:Windows 10 64bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:27396

Description

We have encountered a problem on all of our machines, if we have Vectorworks 2018 installed.
After a little bit of research it appears, that Vectorworks 2018 is also copying files upon installation to the system32 folder.
Those files are the following:
Qt5Core.dll, Qt5Gui.dll, Qt5Network.dll, Qt5OpenGL.dll, Qt5Widgets.dll, Qt5Xml.dll (Version of all the Dlls: 5.5.1.0, 05.04.2018 08:51)

After the installation of Vectorworks, QGIS won't start. Attached are the screenshots of the error messages.
The workaround to solve this problem, is to delete/rename/move the ddl's from the system32 folder. After that step is done, QGIS will work just fine.

So far we did not figure out what effects the removal of the dll's might have on the software/systems.

History

#1 Updated by Pascal Mages over 1 year ago

I can confirm this Bug with QGIS 3.2.1 and Vectorworks 2018!

Renaming the mentioned DLLs works for me. Vectorworks does not seem to be affected.

I'll gladly help resolving this problem by providing further information or testing.

#2 Updated by Markus Meyer over 1 year ago

  • Status changed from Open to Closed

#3 Updated by Pascal Mages over 1 year ago

Why did you close this bug?

#4 Updated by Markus Meyer over 1 year ago

  • Status changed from Closed to Reopened

I thought the problem comes from Vectorworks, since those files are older then the ones used from QGIS.
I will leave the case open for now.

#5 Updated by Giovanni Manghi over 1 year ago

  • Resolution changed from worksforme to invalid

Pascal Mages wrote:

Why did you close this bug?

because the "DLL hell" caused by other programs is not a QGIS issue: no program installer should ever put any DLL (potentially used by other programs) in the system32 folder.

#6 Updated by Markus Meyer over 1 year ago

  • Status changed from Reopened to Closed

Thank you Giovanni.
I will go ahead and close the case now.

Also available in: Atom PDF