Bug report #19556

QGIS 3.2.1 - WMS server URL not accepted

Added by Armand Bahi about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:3.2.1 Regression?:No
Operating System:Ubuntu 18 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:27383

Description

I have a WMS server running with mapserver on https://demo.veremes.net/wms/public/cd59_raster?service=WMS&version=1.3.0&request=GetCapabilities

When adding the layer I got the "Invalid Layer : Raster layer Provider is not valid" error

But if I copy the GetCapabilities result on a file and put it on https://demo.veremes.net/cd59_raster then it works

It seems like something on the first URL is not accepted

Screenshot_20180807_095612.png (1.36 MB) Giovanni Manghi, 2018-08-07 10:56 AM

History

#1 Updated by Giovanni Manghi about 2 years ago

Just tested on master and looks fine here (see attached image).

#2 Updated by Armand Bahi about 2 years ago

I've tried on Windows and it works too, it seems the problem is on the linux version (tested on 3.2.1+28bionic amd64)

#3 Updated by Giovanni Manghi about 2 years ago

Armand Bahi wrote:

I've tried on Windows and it works too, it seems the problem is on the linux version (tested on 3.2.1+28bionic amd64)

try clean the cache in your qgis linux installation.

#4 Updated by Armand Bahi about 2 years ago

It doesn't change anything

#5 Updated by Giovanni Manghi about 2 years ago

Armand Bahi wrote:

It doesn't change anything

on the same network does it work on a different machine?

#6 Updated by Robert Rigo about 2 years ago

I may have similar problem. I want to load _http://geoportal.dgu.hr/services/inspire/orthophoto_2014-2016/wms into qGIS 3.2.1 but I get error "Invalid Layer : Raster layer Provider is not valid (provider: wms, URI: crs=EPSG:3765&dpiMode=7&format=image/png&layers=OI.OrthoImagery&styles=&url=http://geoportal.dgu.hr/services/inspire/orthophoto_2014-2016/wms".

But, when I load WMS layer in 2.18.20, it loads like charm. Then I save project file in 2.18.20. Then I open project file (saved in 2.18.20) in 3.2.1. and WMS layer is there which is strange. Then I remove WMS layer in 3.2.1 and try to load same layer in 3.2.1 and I get same error. I am using Windows 7. BTW: this is my first issue report, sorry if I did it wrong.

#7 Updated by Giovanni Manghi about 2 years ago

Robert Rigo wrote:

I may have similar problem. I want to load _http://geoportal.dgu.hr/services/inspire/orthophoto_2014-2016/wms into qGIS 3.2.1 but I get error "Invalid Layer : Raster layer Provider is not valid (provider: wms, URI: crs=EPSG:3765&dpiMode=7&format=image/png&layers=OI.OrthoImagery&styles=&url=http://geoportal.dgu.hr/services/inspire/orthophoto_2014-2016/wms".

But, when I load WMS layer in 2.18.20, it loads like charm. Then I save project file in 2.18.20. Then I open project file (saved in 2.18.20) in 3.2.1. and WMS layer is there which is strange. Then I remove WMS layer in 3.2.1 and try to load same layer in 3.2.1 and I get same error. I am using Windows 7. BTW: this is my first issue report, sorry if I did it wrong.

on what OS do you observe this?

#8 Updated by Armand Bahi about 2 years ago

So I tried on a Debian 9 and it worked correctly, I'm going to create a new Ubuntu 18 and test on it

#9 Updated by Armand Bahi about 2 years ago

Seems to work on an other Ubuntu18 machine, I'll reinstall it on mine, do you want to make some tests before I do it ?

#10 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

Armand Bahi wrote:

Seems to work on an other Ubuntu18 machine, I'll reinstall it on mine, do you want to make some tests before I do it ?

this suggest the issue is caused by something very specific in your original qgis installation, hard to say what exactly. If you find it please reopen this ticket.

#11 Updated by Robert Rigo about 2 years ago

Giovanni Manghi wrote:

Robert Rigo wrote:

I may have similar problem. I want to load _http://geoportal.dgu.hr/services/inspire/orthophoto_2014-2016/wms into qGIS 3.2.1 but I get error "Invalid Layer : Raster layer Provider is not valid (provider: wms, URI: crs=EPSG:3765&dpiMode=7&format=image/png&layers=OI.OrthoImagery&styles=&url=http://geoportal.dgu.hr/services/inspire/orthophoto_2014-2016/wms".

But, when I load WMS layer in 2.18.20, it loads like charm. Then I save project file in 2.18.20. Then I open project file (saved in 2.18.20) in 3.2.1. and WMS layer is there which is strange. Then I remove WMS layer in 3.2.1 and try to load same layer in 3.2.1 and I get same error. I am using Windows 7. BTW: this is my first issue report, sorry if I did it wrong.

on what OS do you observe this?

On Windows 7. Should I open new ticket, since this one is closed?

#12 Updated by Giovanni Manghi about 2 years ago

On Windows 7. Should I open new ticket, since this one is closed?

the observations above point to a local (installation? cache? network?) issues, not a qgis one. Please try on a different machine, in the same network (with a clean installation/profile) and see if still does not work.

#13 Updated by Alex Hajnal over 1 year ago

FWIW, clearing the QGIS cache (Settings → Options → Network → Cache settings → Clear) fixed the issue for me. I'm using QGIS 2.16.0 (GDAL/OGR 1.11.3).

Also available in: Atom PDF