Bug report #1942

Allow more decimal/integer places in the labels font size selector

Added by cgsbob - almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12002

Description

In order to create labels on a feature in geographic CRS, you must have a font size >= 0.01 degrees (which is about 870 meters in one of my locations) and set the font size to Map units. This often creates very large labels.

My solution to this problem is to reproject this data in a projected CRS. A better solution to this problem is to allow more then 2 decimal places in the Font size spinbox and other spinboxes in the Labels tab.

Associated revisions

Revision 669bddff
Added by Jürgen Fischer almost 10 years ago

fix #1942

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision afc55a1d
Added by Jürgen Fischer almost 10 years ago

fix #1942

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Giovanni Manghi almost 10 years ago

The same is true when map units are meters. In this case the problem is the opposite as it is necessary to define labels that are defined by 3 or more integers to see big enough labels when you zoom out. See #1942.

#2 Updated by Giovanni Manghi almost 10 years ago

sorry I mean #1972

#3 Updated by Jürgen Fischer almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in afc55a1d (SVN r11773)

#4 Updated by Giovanni Manghi almost 10 years ago

Replying to [comment:3 jef]:

fixed in afc55a1d (SVN r11773)

Hi,

thanks for the fix.

it would be possible to disable the label preview for font sizes (in map units) > than a certain value? If by mistake (or not) a very big size is selected the dialog box become suddenly very wide and exits the limits of the screen.

#5 Updated by Jürgen Fischer almost 10 years ago

Replying to [comment:4 lutra]:

it would be possible to disable the label preview for font sizes (in map units) > than a certain value? If by mistake (or not) a very big size is selected the dialog box become suddenly very wide and exits the limits of the screen.

just for the record: duplicate of #2014

Also available in: Atom PDF