Bug report #19392

Problem to open protocol Links GeoJSON

Added by Jean-Louis Stanus about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:2.18.20 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:27220

Description

When i try to open links as exemple :

it generates errors as seen on pictures.

If the same service exists without ssl/https (so http), it can be opened without any problem.
The problem is the same in 3.2 windows.

OS : Windows 10 - 64 bits
Versions : 2.18.21 / 3.2
Builds : OSGEO4w

I tested on linux ubuntu 16.04 ppa build. All the links are opened without error.

Additional informations :
https://gis.stackexchange.com/questions/242559/error-when-add-geojson-protocol-layer-in-qgis?noredirect=1#comment463434_242559

open_url_geojson.PNG - error when opened (259 KB) Jean-Louis Stanus, 2018-07-11 03:04 PM

open_url_geojson.PNG - trying to open the url (259 KB) Jean-Louis Stanus, 2018-07-11 03:05 PM

History

#1 Updated by joe larson almost 2 years ago

Guessing this is a duplicate of https://issues.qgis.org/issues/17947

#2 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Closing the older one as the newer has more details.

Also available in: Atom PDF