Bug report #19326

WMS: something is going wrong...

Added by Richard Duivenvoorde about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27154

Description

In current master (QGIS code revision 497637b8a5) something is going wrong with WMS coords.

To reproduce:

- create EPSG:28992 empty project
- from WFS service: https://geodata.nationaalgeoregister.nl/bestuurlijkegrenzen/wfs?version=1.0.0&request=GetCapabilities
load layer: bestuurlijkegrenzen:provincies
You should see the provinces of NL
- from WMS service: https://geodata.nationaalgeoregister.nl/bestuurlijkegrenzen/ows?SERVICE=WMSx%x%
load layer: provincies
If you do NOT change the epsg, but keep it 4326 you will NOT get a map.

Another way:
- create a project 4326
- open WMS layer provincies: No map.

I see in debug window:

https://geodata.nationaalgeoregister.nl/bestuurlijkegrenzen/ows?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetMap&LAYERS=provincies&STYLES&WIDTH=2147483647&HEIGHT=-1606881664&FORMAT=image/png&CRS=EPSG:4326&DPI=96&MAP_RESOLUTION=96&FORMAT_OPTIONS=dpi:96&TRANSPARENT=TRUE&BBOX=53.58278517693342025,3.20518236682698143,3799937.26855485513806343,5078278.88565741013735533

Looks like the BBOX is a mix of epsg:4326 and epsg:28992

Strange thing is that if you save it as a project, all will be fine IF you open the project in a new session.
I see this only in master, 3.2 and 2.18 are fine for what I see.

Attached some project files (which just work, as said)

wmsmaster.qgz (4.13 KB) Richard Duivenvoorde, 2018-07-03 08:01 PM

wms218.qgs (12 KB) Richard Duivenvoorde, 2018-07-03 08:01 PM

wms32.qgz (4.06 KB) Richard Duivenvoorde, 2018-07-03 08:01 PM

History

#1 Updated by Richard Duivenvoorde almost 2 years ago

  • Status changed from Open to Closed

Cannot reproduce anymore.
Closing myself.

Also available in: Atom PDF