Bug report #19294

Wrong parameter type to VoronoiPolygons in Processing

Added by Håvard Tveite about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:3.2 Regression?:No
Operating System:Ubuntu 16.04 (and all others) Easy fix?:Yes
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27122

Description

In /python/plugins/processing/algs/qgis/VoronoiPolygons.py, the
parameter type of the "BUFFER" parameter is set to QgsProcessingParameterDistance.
This seems to be wrong, because this is a percentage (the percentage to increase the extent with) and not a distance.
QgsProcessingParameterNumber should therefore be used instead of QgsProcessingParameterDistance.

https://github.com/qgis/QGIS/pull/7325

Associated revisions

Revision a756fb10
Added by Håvard Tveite about 2 years ago

Fix parameter type for the BUFFER parameter of the Voronoi polygons alg

Fixes #19294

Revision c409d5aa
Added by Håvard Tveite about 2 years ago

Fix parameter type for the BUFFER parameter of the Voronoi polygons alg

Fixes #19294

(cherry-picked from a756fb103)

History

#1 Updated by Håvard Tveite about 2 years ago

The pull request was removed for technical reasons.
Have now created a new one: https://github.com/qgis/QGIS/pull/7326

#2 Updated by Håvard Tveite about 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF