Bug report #19271

Crash on SQL queries - virtual layers

Added by Bugmi Gnott about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:3.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:27099

Description

Steps to reproduce:
  • New project
  • New temporary vector (name "asd", geometry: LineString)
  • Draw a line
  • Menu Database -> DB Manager, click on Virtual Layers -> QGIS layer -> asd, open the SQL window
  • Run query: "SELECT * FROM asd;", query should run OK
  • Run query: "SELECT geometry FROM asd;", query should run OK
  • Run query: "SELECT GLength(geometry) FROM asd;", query should run OK
  • Run query: "SELECT *", crash occurs
  • Run query: "SELECT geometry_n FROM asd;", crash occurs
  • Run query: "SELECT NoSuchFunction(geometry) FROM asd;", crash occurs

See attached file for stack trace

crash.txt Magnifier (1.31 KB) Bugmi Gnott, 2018-06-26 04:27 PM

History

#1 Updated by Jürgen Fischer about 2 years ago

  • Subject changed from QGIS 3.2.0 - Crash on SQL queries to Crash on SQL queries

#2 Updated by Stephen Knox almost 2 years ago

I can't reproduce a crash on the queries flagged, although they don't work, but that isn't surprising since they don't seem to be valid SQL. Perhaps a close candidate as time has moved on?

#3 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

#4 Updated by Regis Haubourg almost 2 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable
  • Priority changed from High to Normal

Tested here with latest nightlies.

I get "database error" messages in a popup but no QGIS crash.

For sure the error message are not really informative but this would be more a feature request to improve that part of DBmanager (would be really nice to have verbose messages from spatialite / SQLITE)

Please reopen if the crash still occurs

#5 Updated by Regis Haubourg almost 2 years ago

  • Subject changed from Crash on SQL queries to Crash on SQL queries - virtual layers

Also available in: Atom PDF