Bug report #19224

Qgis crashes when deleting or moving node

Added by Maja Polenšek almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Editing
Affected QGIS version:3.0.3 Regression?:No
Operating System:Windows 10 pro Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:27053

Description

I am working with polygons (shapefile). I can delete or move few nodes. After that qgis crash. Sometimes it freezes (mouse is working) and does not complete the command. If I close and reopen Qgis it works normal for few moves. At best I can work 5 to 10 minutes before it crashes. Sometimes I can make just 3 changes.

qgis crash.txt Magnifier - Qgis crash report (1.36 KB) Maja Polenšek, 2018-06-19 10:24 AM

Selection_601.png - Start New Profile (39.4 KB) Richard Duivenvoorde, 2018-06-22 01:07 PM

History

#1 Updated by Martin Dobias almost 2 years ago

  • Status changed from Open to Feedback

Could you please attach the data you have been using?

Ideally if you could also record a short screen recording where it is possible to see how you do the editing...

#2 Updated by Richard Duivenvoorde almost 2 years ago

Maja sent the shp file to redmine address, I forwarded it to Martin.
If somebody else wants it, let me (Richard) know.

Note: I cannot reproduce the crash here: tried to edit the shapefile by adding features en edit excisting ones...
(I'm not on Windows though...)

@Maja: can you try to create a fresh 'Profile' in QGIS? So to be sure there are no plugins screwing things up?

#3 Updated by Richard Duivenvoorde almost 2 years ago

Via menu Settings / User Profiles / New Profile, see screenshot

#4 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF