Bug report #19206

Ctrl+C doesn't copy, despite dialog prompt

Added by Loren Amelang over 2 years ago. Updated about 2 years ago.

Status:Open
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:3.0.3 Regression?:No
Operating System:Windows 10 Creators with 3000x2000 screen and 175% scaling Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27035

Description

As the Subject says, In almost every place I've tried it, Ctrl+C is ignored but using the dialog Copy command works. The screenshot shows the Python Console, but it is definitely not confined to Python. Ctrl+C doesn't work in Log Messages, but at least that dialog doesn't show the Ctrl+C hotkey.

I'd much rather the hotkey worked everywhere, but if there is some reason why it can't, is there some way to warn us we're in one of those places before we assume it did and paste some previous buffer we don't want? Maybe a failed Ctrl+C causes an error sound? Or a successful one causes a confirmation sound?

Right now the only practical strategy is to assume the hotkey won't work and use the dialog Copy click.

Ctrl+C doesn_t Copy.jpg (100 KB) Loren Amelang, 2018-06-16 01:52 AM

History

#1 Updated by Jürgen Fischer about 2 years ago

  • Subject changed from Ctrl+C doesn't copy, despite dialog prompt, in 3.0.3 to Ctrl+C doesn't copy, despite dialog prompt

Also available in: Atom PDF