Bug report #19180

Treating UUID like text

Added by Rémi Desgrange over 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:3.0.3 Regression?:No
Operating System:all Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27009

Description

I have layer from postgis and here are some call from qgis 3 (from 3.0.0 to qgis 3.0.3) that makes errors :

SELECT "id"::text FROM (SELECT DISTINCT "id" FROM "my_schema"."v_mylayer" WHERE "id" ILIKE '%41bbe618-5399-4ca1-a50c-4be1a0acb9d1%' ORDER BY "id") foo

(this is from postgresql logs)

v_mylayer is a view. Postgresql 10.4, postgis 2.4. this error appends on all operating system, mac os, linux windows (7&10)

Associated revisions

Revision e3f63d88
Added by Jürgen Fischer about 2 years ago

postgres provider: cast to text in uniqueStringsMatching (fixes #19180)

History

#1 Updated by Rémi Desgrange about 2 years ago

This bug is still present in 3.2.3, on all OS. It also break the ability to cut a linestring. Since it want to created a new uuid like `<uuid>_1`

#2 Updated by Jürgen Fischer about 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

#3 Updated by Jürgen Fischer about 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF