Bug report #19172

QGIS 3.0.3 main window does not remember chosen size (Win 10 with scaling...)

Added by Loren Amelang almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:3.0.3 Regression?:No
Operating System:Windows 10 Creators, Surface Book with 175% screen scaling Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27001

Description

I'm brand new to QGIS, so sorry if I'm missing something obvious. But it looks like this was all handled many years ago, that QGIS should save the GUI dimensions on exit and restore them next time. Mine opens in the same tiny rectangle in the same position every time. And I suspect that rectangle is in unscaled pixels while all the contents are getting scaled almost double-size. I have to drag every window and pane about twice as big, every time I start it. And every time it crashes...

I did try choosing odd height/width combinations, and it is not storing scaled pixel counts and restoring them unscaled. It is just choosing the same tiny default size every time.

Looks like in the screenshot the Browser - Layers column has remained wider, but the whole window has not. Note Meazure is showing real 3000x2000 hardware pixels, not the scaled logical pixels.

Is there some way for me to hack this for now?

QGIS Default Size.JPG - Screenshot with dimensions (257 KB) Loren Amelang, 2018-06-12 04:08 AM

History

#1 Updated by Loren Amelang almost 2 years ago

Today QGIS began remembering its window size and position! I have no idea what changed... I don't believe I did anything in QGIS that I hadn't tried several times before.

Well, I did finally get my
PS C:\Program Files\QGIS 3.0\apps\saga-ltr> .\saga_cmd ta_profiles "Cross Profiles" ...
command to work. And the RiverGIS plugin finally was able to export my HEC-RAS file. Can't imagine that matters.

I know Windows 10 was acting very strangely yesterday... I had LibreOffice Writer open, and tried to print to PDF with PrimoPDF, and it locked up, and the Windows Snipping tool also locked up, and my EverDesk eMail client locked up. Seemed it couldn't run them simultaneously, but any two would work. Windows had to be manually restarted, and the restart installed a bunch of updates. I can't imagine how that would affect QGIS...

If I notice any more clues I'll definitely post them here!

#2 Updated by Loren Amelang almost 2 years ago

Since the last report I've seen 3.0.3 open centered on screen in its tiny default size one time. Mostly it was remembering my choices.

So far 3.2 has always remembered my choices!

#3 Updated by Loren Amelang almost 2 years ago

  • Status changed from Open to Closed

Today something broke the size memory for for my QGIS 3.2: #19386

Since I can't edit the Subject here, I made the new issue and closed this one.

Also available in: Atom PDF