Bug report #1916

(windows) : "Access violation - No RTTI Data!"

Added by Giovanni Manghi about 11 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Legend
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11976

Description

This is the message that appears under windows (Vista, Xp) when clicking (every time) with the left mouse button on a layer in the legend. The error is not critical as does not crash the application but is very annoying as restarting qgis is necessary to make it disappear. It seems to not related to the data being used and seems also to appear always after working a while with the program. Tested on qgis >= 1.2

capture1.jpg (70 KB) Giovanni Manghi, 2009-09-03 06:41 AM

Associated revisions

Revision af62f1ce
Added by Jürgen Fischer about 11 years ago

fix #1916

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 93e3bb32
Added by Jürgen Fischer about 11 years ago

fix #1916

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer about 11 years ago

I've seen that too, but I'm not able to reproduce it reliably. Just left clicking doesn't do it here. It only happens after some other action, which I wasn't able to identify yet.

#2 Updated by Giovanni Manghi about 11 years ago

Replying to [comment:1 jef]:

Just left clicking doesn't do it here.

Here too, but seems to appear in any case sometime after working on a project. Doesn't seems to me to be associated to any particular action.

#3 Updated by Jürgen Fischer about 11 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Replying to [comment:2 lutra]:

Replying to [comment:1 jef]:

Just left clicking doesn't do it here.

Here too, but seems to appear in any case sometime after working on a project. Doesn't seems to me to be associated to any particular action.

Happened when a layer was removed, that was dragged, but not actually moved.
Fixed in 93e3bb32 (SVN r11694)

#4 Updated by Jürgen Fischer about 11 years ago

Replying to lutra:

This is the message that appears under windows (Vista, Xp) when clicking (every time) with the left mouse button on a layer in the legend. The error is not critical

BTW it was critical - as the linux version crashed in the same situation.

#5 Updated by Giovanni Manghi almost 11 years ago

I have seen this popping out on a Vista machine of a friend... just once while working in the legend, without annoying further...

#6 Updated by Giovanni Manghi over 10 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

it is pretty common to still spot this problem under every windows version. Tested with qgis 1.4/trunk installed with osego4w installer.

#7 Updated by Giovanni Manghi over 10 years ago

Maybe the recent patches by Giuseppe for the legend also fixed this? needs to be checked.

#8 Updated by Giovanni Manghi about 10 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Replying to [comment:8 lutra]:

Maybe the recent patches by Giuseppe for the legend also fixed this?

seems so, so I'll close.

Also available in: Atom PDF