Bug report #19083

copy paste attributes to spreadsheet bad behaviour in QGIS3

Added by Erik Meerburg over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Attribute table
Affected QGIS version:3.0.3 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:26913

Description

Hi,

One of the lovely features in QGIS is to copy a selection of objects from the attribute table to a spreadsheet (Libre Office Calc in my setup). In 2.18, this gives all attributes including the geometry.

Doing the same in QGIS 3, the result is that Calc interpretes this so slow, that it practically hangs. I've updated QGIS from 3.02 to 3.03, and I've had a few of my students test this as well, with the same result: perfect in 2.18, extreme slow results from 3.

I tried this with a very simple set (two objects with just four points each) and here the issue is less problematic. However, when doing the same with larger objects like municipalities (Dutch: gemeenten), the whole function becomes useless, even when I just copy two objects.

My guess would be that QGIS 3 copies something to the clipboard that doesn't work well with other applications.

Kind regards,
Erik.

History

#1 Updated by Erik Meerburg over 2 years ago

  • Status changed from Open to Closed

#2 Updated by Erik Meerburg over 2 years ago

When copying the features to Notepad++, there was no real noticable difference between data from QGIS 3.03 or 2.18, apart from the fact that 2.18 exports the features as Polygons, while 3.03 exports the same features as MultiPolygons.

Both versions of QGIS had as export settings "Plain text, WKT-geometry". In NotePad++ the result was as expected. So after all, might not be a QGIS issue.

Changing the export settings to "Plain text, no geometry" gave normal behaviour in Calc. Still no excuse for hanging with geometry fields from QGIS3, but... not worth a bugreport. Sorry to have filed this one before doing more research.

Also available in: Atom PDF