Bug report #18914

[macOS] Plugin list corrupted by wrongly placed checkboxes on Mac

Added by Russell Fulton 5 months ago. Updated 19 days ago.

Status:Open
Priority:Normal
Assignee:-
Category:mac_os_specific
Affected QGIS version:3.0.2 Regression?:No
Operating System:Mac OS 10.13.4 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No

Description

Working on a Mac (if it matters)

I am developing a new plugin for qgis 3 on a Mac using plugin builder following instructions in the latest version of The PyQGIS Programmer’s Guide. I have now got got the point where I have compiled the skeleton code and loaded it into QGIS. The plugin appears in the plugin manager as installed.

The instruction say one must then click the check box to enable the plugin but there are no checkboxes next to the plugin names, just one at the top of the column which is not properly aligned with the text.

screen shot attached.

Screen Shot 2018-05-03 at 11.55.00 AM.png (31.6 KB) Russell Fulton, 2018-05-05 11:02 PM

History

#1 Updated by Borys Jurgiel 5 months ago

  • Subject changed from can not load local plugins in QGIS 3.02 on a Mac to Plugin list corrupted by wrongly placed checkboxes on Mac

Looks like all the checkboxes overlap in one place. I believe it affects all the plugin tabs on the left (not just installed plugins), doesn't it?

#2 Updated by Salvatore Larosa 4 months ago

a Qt issue, fixed with 5.11.0 version. (from homebrew)

#3 Updated by Borys Jurgiel 4 months ago

  • Assignee deleted (Borys Jurgiel)
  • Category changed from Plugin Manager to Build/Install
  • Subject changed from Plugin list corrupted by wrongly placed checkboxes on Mac to [macOS] Plugin list corrupted by wrongly placed checkboxes on Mac

So it seems it's macOS package issue.

#4 Updated by Denis Rouzaud 19 days ago

  • Category changed from Build/Install to mac_os_specific

Also available in: Atom PDF