Bug report #18897

can't see layers on canvas loaded from XYZ Tiles in QGIS 3 on Mac

Added by Russell Fulton almost 2 years ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/XYZ
Affected QGIS version:3.1(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:26729

Description

I am trying to load background map from OSM and having problems. The data source browser->XYZ Tile comes 'pre loaded' with a link for standard OSM and this works fine.

When I try to add a new source (right click -> new connection...) and fill out the dialogue with the Tile url from OSM the item appears in the menu but when I click on it I get a legend entry but no layer is displayed.

I have looked through the message but could not find anything relevant.

I posted a question to stackGIS https://gis.stackexchange.com/questions/281365/trouble-using-xyz-tiles-in-qgis-3-on-mac and got one suggestion to try changing the CRS of the canvas to match that of the background layer but that had no effect.

I have also tried Thunderforest links with api key but got the same result.

History

#1 Updated by Johannes Kroeger about 1 year ago

  • Resolution set to invalid
  • Status changed from Open to Closed

This was a user error and sadly the submitter was not caring enough to mark it as solved here or at their GIS.SE question: https://gis.stackexchange.com/questions/281365/trouble-using-xyz-tiles-in-qgis-3-on-mac

#2 Updated by Russell Fulton about 1 year ago

Humble apologies.

Also available in: Atom PDF