Bug report #1888

Image file filter in "save as picture" dialog is not working

Added by Yves Jacolin about 11 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:11948

Description

If I try do save again my map as a picture, the dialog box does not show files with the same extension as the filter.

the filter hide all files !

Release used: QGIS trunk, r11362

History

#1 Updated by Marco Hugentobler about 11 years ago

Hm, the filter seems to work for me here (tested with jpg and png). Which version of Qt are you using?

#2 Updated by Yves Jacolin about 11 years ago

Hi,

I am using Qt 4.3.4. I am downloading Qt 4.5 and will test it as soon as possible.

Regards,

Y.

#3 Updated by Yves Jacolin about 11 years ago

Hello,

I failed to build QGIS with qt4.5.2. QGIS tells me that it runs with qt4.5.2 but is built with qt4.3.4 :( In this way, the extension filter doesn't work in printing component with QGIS trunk.

Y.

#4 Updated by Giovanni Manghi about 11 years ago

works for me also. Qgis from trunk compiled on ubuntu 9.04, compiled and running against qt 4.5.0

#5 Updated by Giovanni Manghi about 11 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

It works fine also under windows (qt 4.5.2, under linux works fine with also qt 4.5.0). Closing, reopen if after upgrading qt the problem persist.

Also available in: Atom PDF